Module "@babel/runtime/helpers/interopRequireDefault" does not exist in Haste module map

Description

You might encounter an error saying something about Module "@babel/runtime/helpers/interopRequireDefault" does not exist in Haste module map.

Probably this bug is related to newest React Native versions. I've encountered an error on fresh React Native installation with version 0.57.

I'm not going to dive into what the heck is going on. Just will provide simple fix.

Solution

The answer was found under original bug description.

Install Babel core and runtime packages

$ npm install --save-dev @babel/core
$ npm install --save-dev @babel/runtime

then reset cache

$ react-native start --reset-cache

and reload application.

After that application will show up

Links

Original bug [21310]

Answer with fix